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Safety Summary
The following general safety precautions must be observed during all phases of operation of this 
instrument. Failure to comply with these precautions or with specific warnings or operating 
instructions in the product manuals violates safety standards of design, manufacture, and intended 
use of the instrument. Keysight Technologies assumes no liability for the customer's failure to comply 
with these requirements. Product manuals are provided with your instrument on CD-ROM and/or in 
printed form. Printed manuals are an option for many products. Manuals may also be available on 
the Web. Go to www.keysight.com and type in your product number in the Search field at the top of 
the page.

General Do not use this product in any manner not specified by the manufacturer. The protective features of 
this product may be impaired if it is used in a manner not specified in the operation instructions.

Before Applying
Power

Verify that all safety precautions are taken. Make all connections to the unit before applying power. 
Note the instrument's external markings described in “Safety Symbols”.

Ground the
Instrument

If your product is provided with a grounding type power plug, the instrument chassis and cover must 
be connected to an electrical ground to minimize shock hazard. The ground pin must be firmly 
connected to an electrical ground (safety ground) terminal at the power outlet. Any interruption of 
the protective (grounding) conductor or disconnection of the protective earth terminal will cause a 
potential shock hazard that could result in personal injury.

Fuses See the user's guide or operator's manual for information about line-fuse replacement. Some 
instruments contain an internal fuse, which is not user accessible.

Do Not Operate in
an Explosive
Atmosphere

Do not operate the instrument in the presence of flammable gases or fumes.

Do Not Remove the
Instrument Cover

Only qualified, service-trained personnel who are aware of the hazards involved should remove 
instrument covers. Always disconnect the power cable and any external circuits before removing the 
instrument cover.

Cleaning Clean the outside of the instrument with a soft, lint-free, slightly dampened cloth. Do not use 
detergent or chemical solvents.

Do Not Modify the
Instrument

Do not install substitute parts or perform any unauthorized modification to the product. Return the 
product to an Keysight Sales and Service Office for service and repair to ensure that safety features 
are maintained.

In Case of Damage Instruments that appear damaged or defective should be made inoperative and secured against 
unintended operation until they can be repaired by qualified service personnel.

CAUTION
A CAUTION notice denotes a hazard. It calls attention to an operating procedure, practice, 
or the like that, if not correctly performed or adhered to, could result in damage to the 
product or loss of important data. Do not proceed beyond a CAUTION notice until the 
indicated conditions are fully understood and met.

WARNING
A WARNING notice denotes a hazard. It calls attention to an operating procedure, 
practice, or the l ike that, if not correctly performed or adhered to, could resul t in 
personal injury or death. Do not proceed beyond a WARNING notice until the ind icated 
cond itions are fully understood and met.

http://www.keysight.com
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Safety Symbols

Table 1  Safety Symbol

Symbol Description

Direct current

Alternating current

Both direct and alternating current

Three phase alternating current

Three phase alternating current

Earth ground terminal

Protective earth ground terminal

Frame or chassis ground terminal

Terminal is at earth potential

Equipotentiality

N Neutral conductor on permanently 
installed equipment

L Line conductor on permanently installed 
equipment

On (mains supply)

Off (mains supply)

Standby (mains supply). The instrument is 
not completely disconnected from the 
mains supply when the power switch is in 
the standby position

In position of a bi-stable push switch
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Out position of a bi-stable push switch

Equipment protected throughout by 
DOUBLE INSULATION or REINFORCED 
INSULATION

Caution, refer to accompanying 
documentation

Caution, risk of electric shock

Do not apply around or remove from 
HAZARDOUS LIVE conductors

Application around and removal from 
HAZARDOUS LIVE conductors is 
permitted

Caution, hot surface

Ionizing radiation

CAT I IEC Measurement Category I

CAT II Measurement Category II

CAT III Measurement Category III

CAT IV Measurement Category IV

Symbol Description
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Compliance and Environmental Information

Table 2  Compliance and Environmental Information

Safety Symbol Description

CSA is the Canadian certification mark to demonstrate compliance with the Safety 
requirements.

The C-tick mark is a registered trademark of the Spectrum Management
Agency of Australia. This signifies compliance with the Australia EMC
Framework regulations under the terms of the Radio Communication Act
of 1992.

CE compliance marking to the EU Safety and EMC Directives.
ISM GRP-1A classification according to the international EMC standard.
ICES/NMB-001 compliance marking to the Canadian EMC standard.
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DDR/LPDDR Post Process Compliance—At a Glance
The DDR/LPDDR Post Process Compliance Tool evaluates the captured DDR/LPDDR data against a 
set of user-defined limits to help you validate that a memory system is operating properly. The bus 
types supported by this tool are:

- DDR1/2/3/4

- LPDDR1/2/3/4

The automated test application guides you through the process of selecting and configuring tests, 
running tests, and evaluating the test results.

The application assumes that the Keysight logic analysis system has already been set up to properly 
capture DDR data.

To use the automated test application, see:

• Chapter 2, "Starting the DDR/LPDDR Post Process Compliance Tool" on page 15

• Chapter 3, "Configuring Tests" on page 19

• Chapter 4, "Setting Up the Test Environment" on page 27

• Chapter 5, "Selecting Tests" on page 29

• Chapter 6, "Running Tests" on page 33

• Chapter 7, "Automating the Tests" on page 37

• Chapter 8, "Viewing Results" on page 41

• Chapter 9"Viewing/Exporting/Printing the Report" on page 45

• Chapter 10 "Saving Test Projects" on page 51

• Chapter 11, "Creating or Opening a Test Project" on page 53
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1 About the Tool

Overview of the
tests

There are two types of tests:

• Tests which check for timing violations

• Tests which check for illegal DDR state transitions

The test limits can be (and must be) configured by the user.

The provided timing violation tests include:

Compatibility The DDR/LPDDR Post Process Compliance Tool works for most DDR, DDR2, DDR3, DDR4, LPDDR, 
LPDDR2, LPDDR3 and LPDDR4 systems.

The tool is not able to fully model systems which use the following optional DDR features:

• Partial Array Self-Refresh (PASR)

• Auto Self-Refresh (ASR)

• On-the-fly Burst Length switching

Parameter Description Test

tRASmax Row Active time ACTIVATE to PRECHARGE/Auto-PRECHARGE must be < tRASmax

tRASmin Row Active time ACTIVATE to PRECHARGE/Auto-PRECHARGE must be > tRASmin

tRP PRECHARGE to any other command (same bank) must be > tRP

tCCD Time between any read or write command must be > tCCD

tRRD ACTIVATE to ACTIVATE (any bank) must be >= tRRD

tFAW Time for four ACTIVATEs (any bank) must be >= tFAW

tRFC REFRESH to REFRESH or ACTIVATE must be > tRFC

tDARW ACTIVATE to external READ/WRITE must be > tDARW

tDRP Read to Precharge/AutoPrecharge must be > tDRP

tDRW Read to Write must be > tDRW

tDWP Write to Precharge/AutoPrecharge must be > tDWP

tDWR Write to Read must be > tDWR

Description

READ or WRITE to an inactive row

REFRESH to an active bank

ACTIVATE to an active bank
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About the software The Post Process Compliance Tool is part of the Keysight B4661A DDR/LPDDR Toolset package. This 
tool requires that you install the Logic and Protocol Analyzer software version 6.2 or higher. Versions 
prior to 6.2 do not support this tool.

Software License The DDR/LPDDR Post Process Compliance Tool requires B4661A_3 license to operate. If this license 
is not installed in your system, the following license error dialog box is displayed while launching the 
DDR/LPDDR Post Process Compliance Tool application.
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About the Tool 1

When you are launching the DDR/LPDDR Post Process Compliance Tool for the first time, the 
Keysight Technologies Software End User License Agreement dialog box appears. You can read the 
agreement and choose to agree or disagree before proceeding further to use the DDR/LPDDR Post 
Process Compliance Tool.
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2 Starting the DDR/LPDDR Post 
Process Compliance Tool

1 From the logic analysis system's main menu, choose Tools > External Applications > DDR/LPDDR Post 
Process Compliance Tool.

The DDR/LPDDR Post Process Compliance Tool window appears.
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See Also • “To Toggle between the Toolbar" on page 17

Next • “Creating or Opening a Test Project" on page 53
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Starting the DDR/LPDDR Post Process Compliance Tool 2

To Toggle between the Toolbar

To toggle between the toolbars, you can click and drag the toolbars accordingly. To keep the default 
display for the toolbars, select View>Preferences>Tab Layout from the menu.
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3 Configuring Tests

You must configure a set of limits in Configure tab before you can run any tests.

These limits describe the memory part you are using and certain characteristics of the memory bus.

You can load, edit, and apply limits in Limits menu.

See Also • “To set the test limits" on page 20 (for information on how to calculate the limits)

• “To create/edit limit sets" on page 24 (for information on how to enter and save the limits)

• “To activate/refresh limit sets" on page 25 (for information on how to load a limit set which you 
have saved)
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To set the test limits

All timing violation tests are based on compliance limits that are specified by the user. Specify these 
limits based on the specific DDR memory parts you are using. Limits will vary depending on:

• Memory technology (DDR2, DDR3)

• Speed grade

• Clock speed

• Part density

• User selected options such as Additive Latency and burst length

Units Some times must be entered in seconds (s). If the data sheet expresses these limits in terms of clock 
cycles, you will need to convert those limits to seconds.

Each logic analyzer sample has a timestamp. Results will be calculated by subtracting the time 
stamp of the first event from the timestamp of the second event. Note that the time stamps are only 
as good as the time stamp resolution of the logic analyzer card being used (this resolution may be as 
coarse as 2ns; see the Specifications and Characteristics in the logic analyzer's Online help for 
details). The elapsed time includes time during which the DDR clock is inactive.

Other times must be entered as a number of clock cycles (CK). Results will be calculated by counting 
the number of logic analyzer samples between the two events.

Additive latency (AL) is normally expressed as a number of clocks (CK). For some calculations, you 
will need to convert AL to seconds (s) by dividing by the clock rate.

Burst length (BL) is simply an integer (4 or 8).

Definitions of the
limits

You will need to look up some of the limits from the part data sheet. You will then calculate values for 
the derived limits.

Keysight suggests using the formulas here to compute the derived limits. However, it is entirely the 
responsibility of the user to choose limits that are appropriate for the intended application.

Here are the limits you need to specify:

Parameter Description Unit Suggested Definition Reference

tRASmax Row Active time ACTIVE to 
PRECHARGE

s Part dependent (9 * tREFI) Data Sheet (tREFI). See 
DDR3 (see page 24) page 
147.

tRASmin Row Active time ACTIVE to 
PRECHARGE

s Part dependent Data Sheet

tDARW Min ACT to external READ/WRITE s tRCD-AL DDR2 (see page 23) 3.5 / 
DDR3 (see page 24) 12.3

tRP Row Precharge time min PRECHARGE 
to any other command (same bank)

s Part dependent Data Sheet

tDRP Min Read to Precharge CK DDR2: AL + BL/2 + max (tRTP, 2CK) 
-2CK
DDR3: AL + tRTP

DDR2 (see page 23) 3.7.1 
/ DDR3 (see page 24) 
4.13.3

tDRW Min Read to Write CK DDR2: BL/2 + 2CK
DDR3: BL4: RL + CCD/2 + 2CK – WL
DDR3: BL8: RL + CCD + 2CK - WL

DDR2 (see page 23) 
figure 35 / DDR3 (see 
page 24) figure 35, 36

tRFC REFRESH command time. min time 
REFRESH to REFRESH or ACTIVATE

s Part dependent Data Sheet
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Values used to
calculate the limits

To calculate the limits, you will need to look up or calculate the following values:

External Read/Write + AL = Internal Read/Write

Naming
conventions

Limits which are normally expressed as maximum or minimum times have names beginning with 't'.

The names of derived timing limits begin with 'tD'. Derived limits are not usually specified directly in 
the part data sheet. In general, you will compute these from the standard timing parameters.

Limits which are normally expressed as a number of clock cycles have no prefix. In some cases, you 
may need to convert these to seconds for use by the tool.

Customizing the
limits

The definitions are suggestions based on the DDR2/3 standards. There is no requirement that the 
user must set the limits to those specified in the data sheet or in the JEDEC standard. You can set 
the limits however you like, depending on the goals of your testing.

To load and view the limits, you can either use the default limit set or use customized limit sets.

tDWP Min Write to Precharge CK WL + BL/2 + tWR DDR2 (see page 23) 3.7.2 
/ DDR3 (see page 24) 
Figure 49, 50

tDWR Min Write to Read CK DDR2: CL -1 + BL/2 + tWTR 
DDR3: WL + BL/2 + tWTR

DDR2 (see page 23) 
Figure 41 / DDR3 (see 
page 24) Figure 53, 56

tCCD CAS to CAS delay min time between 
any read or write command

CK Part dependent Data Sheet

tRRD Min time between two ACTIVATE 
commans (different banks)

s Part dependent Data Sheet

tFAW Min time for four ACTIVATE 
commands (different banks)

s Part dependent Data Sheet

Parameter Description Unit Suggested Definition Reference

Parameter Description Unit Suggested Definition Reference

AL Additive Latency CK, s User selection System Design

BL Burst Length User selection System Design

CL CAS (Read) Latency CK Part dependent Data Sheet

CWL CAS Write Latency CK Part dependent Data Sheet

RL Read Latency CK AL + CL DDR3 (see page 24) 
3.4.3.4

WL Write latency CK AL + CWL DDR3 (see page 24) 
3.4.3.4

tRCD RAS to CAS Delay (ACT to internal 
R/W)

s Part dependent Data Sheet

tREFI Refresh Interval; average time 
between Refresh commands

s Part dependent Data Sheet

tRTP Internal Read to Precharge s Part dependent (max 4CK or 7.5ns) Data Sheet

tWR Internal Write Recovery s Part dependent Data Sheet

tWTR Internal Write to internal Read s Part dependent (max 4CK or 7.5ns) Data Sheet
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If you are using customized limit sets, you can select the customized compressed archived files (.lim) 
from your local system and click Apply Custom Limit Set... in Limits section.

Example limits An example limit set is supplied with the validation tool. The example is based on a DDR800 part with 
6-6-6 timing.

Example part:

• Data sheet: MICRON DDR3 MT41J256-32 Me x 4 x 8 Banks PDF: 09005aef82f1e6e2 Rev. M 9/08 
EN

• Speed Grade 25 (6-6-6)

• Clock 400 MHz (2.5ns)

• Data Rate 800 MT/s

• Temperature 0-85C

Parameter Value Reference

tREFI 7.8 us (low temp) Data Sheet, page 71

tRASmax 70.2us Data Sheet (tREFI), page 63

tRASmin 37.5ns Data Sheet, page 30

tRP 15ns Data Sheet, page 30

tCCD 4CK (10ns) Data Sheet, page 70

tRRD 10ns Data Sheet, page 30

tFAW 50ns Data Sheet, page 30

tRFC 110ns Data Sheet, page 30

tRCD 15ns Data Sheet, page 30

tRTP 10ns Data Sheet, page 70

tWR 15ns Data Sheet, page 70
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References • DDR2 JEDEC Standard 79-2E, April 2008

• DDR3 JEDEC Standard 79-3C, November 2008

tWTR 10ns Data Sheet, page 70

AL 0ns (0CK) User selected (MR1, 0 means no additive latency)

BL 10ns (8 bursts) User selected (MR0)

CL 6CK (15ns) Data Sheet, page 30 (MR0)

CWL 5CK (12.5ns) Data Sheet, page 116 (MR2)

Parameter Value

RL 6CK (15ns)

WL 5CK (12.5ns)

tDARW 15ns

tDRP 10ns

tDRW 17.5ns

tDWP 32.5ns

tDWR 27.5ns

Parameter Value Reference
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To create/edit limit sets

You can create new limit sets by modifying existing limit sets and saving them to new files.

1 From the DDR/LPDDR Post Process Compliance Tool's main page, choose Edit Limit Values... in 
Limits section.

2 In the Create/Edit User-Defined Limit Set dialog, double-click on the required test for which you 
want to edit the limits.

3 Modify the limit as desired. 

4 Repeat the last two steps until all limits requiring change are modified.

5 Click OK to save your custom limit set to a file. Enter the file name in the Save File As dialog.

• Now, you can activate your newly-created limit set for use in the next run. See “To 
activate/refresh limit sets" on page 25.

When Loading
Projects

When you load a project, the application will attempt to restore the limit set that was in use at the 
time the project was saved.

See Also • “To set the test limits" on page 20 (for information on how to calculate the limits)
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To activate/refresh limit sets

To load a previously defined limit set:

1 From the DDR/LPDDR Post Process Compliance Tool's menu, click Activate/Refresh l imit set....

2 In the Activate/Refresh Compliance Limit Set dialog, select one of the official limit sets or a 
user-defined limit set.

3 Click OK.

NOTE
If you have existing test results when you activate a different limit set, the application examines 
your results to see if any of them would experience a limit change when the different limit set is 
loaded. If any results would be affected in this way, the application tells you which ones they are 
and warns that they must be deleted.
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4 Setting Up the Test Environ-
ment

1 Click the Set Up tab.

2 If more than one DDR bus decoder exists in the logic analysis system setup, select which one to 
use for the compliance tests from the Select a DDR module to analyze listbox.

If only one decoder exists, it will be selected automatically.

If needed, click Refresh to update the list. You may need to refresh the list and select a new 
decoder if you load a new logic analyzer configuration file, or whenever you add or remove a 
decoder.

3 Select the DDR memory type. The DDR/LPDDR Post Process Compliance Tool can work with any 
of the following memory bus standards.

- DDR1/2/3 /4

- LPDDR1/2/3/4

4 From the Set Up section, select whether or not you want the tool to automatically acquire new 
data when compliance tests are run. Whether you plan to run tests once or multiple times, the 
selection of this checkbox instructs the tool to first run the logic analyzer for data acquisition. 
When the data acquisition run is complete, the tool starts post processing the newly acquired 
data by running the selected tests. If you plan to run the tests multiple times or forever, then you 
must select this checkbox to ensure that the tool runs the logic analyzer repetitively for data 
acquisition and then acquires the new data automatically for post processing. 

Deselecting this checkbox instructs the tool to use the already acquired data for post processing. 
The tool does not run the logic analyzer for data acquisition in this case. Therefore, when you 
deselect this checkbox, you can run the tests only once on existing data.

5 (optional) Describe the test for future reference. The specified User Comments will appear on the 
HTML report which is generated for the test.
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Next • “Selecting Tests" on page 29
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5 Selecting Tests

1 Click the Select Tests tab and then select the tests you want to run.

The tests displayed in this tab vary depending on the memory bus type that you selected in the 
Set Up tab.

The following table lists the tests available for the memory bus types.
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Tests Available With B4661A License (DDR Memory Type)

DDR1, 2 tests DDR3 tests DDR4 tests
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Some things to consider while selecting tests:

• Some tests might not make sense for your system. Do not select those tests.

• Checking a parent node/group will check all available sub-groups/tests.

• Unchecking a parent node/group will uncheck all sub-groups/tests.

• A parent node is checked if all subgroups are checked.

• A parent node is unchecked if ANY subgroup is unchecked.

When Tests Have
Already Been Run

Tests Available With B4661A License (LPDDR Memory Type)

LPDDR1 tests LPDDR2 tests LPDDR3 tests
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The marks have the following meanings:

See Also • “To set the test limits" on page 20 (for information on how to calculate the limits)

• “About the Tool" on page 11 (for an overview of the tests performed)

Next • “Configuring Tests" on page 19

Marks Meanings

The test passed.

The test failed.

The test has not been run, or no tests in the group have been run.

The test is currently running.

Some tests in the group have run and passed.

Some tests in the group have run and failed.

Some tests in the group have passed and some have failed; not all of the tests have run.

All tests in the group have run and passed.

All tests in the group have run and failed.
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6 Running Tests

You can use the Run tab to specify how the tests should be run and then run the tests as per these 
settings. 

You can run the tests once or repetitively.

To run the selected tests:

1 Click the Run tab.

2 Configure the settings for running the tests. 

a From the Store Mode section, select which trial results from the test run(s) you want to store. 
You can store results for a maximum of 25 trials.

b From the Run Until section, select the number of times you want to run the tests. Following 
options are available:

• Once - The tests are run once.
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• N Times- The tests are run repetitively for the number of times specified in the Number of 
Runs field.

• Forever- The tests are run repetitively until you press the Stop button.

If you select N Times or Forever, make sure you select the Automatically acquire new logic analyzer 
data when running tests checkbox in the Set Up tab.

c On selecting the N Times option, the Pause in between checkbox is displayed. Select this 
checkbox to instruct the tool to pause the test run after the completion of each run in the 
repetitive run.

d Select the Send email when run is paused or stopped checkbox in the Email section to instruct the 
tool to send a notification email with the information about the test run when the test run 
completes or pauses. You can specify the SMTP Server and the email address to which email 
should be sent in the designated place when this checkbox is selected. You can also specify 
the sender’s email address.

e In the Event section, select the Detect Event checkbox to instruct the tool to perform a specified 
action when the specified event is detected in the test run. On selecting this checkbox, a 
listbox is displayed with this checkbox. From this listbox, you can select either Pause or Stop to 
pause or stop the test run when the selected event is detected during a test run. 

f When you select Event in the Store Mode section or select the Detect Event checkbox, the When 
detect: listbox is displayed to allow you to select the event. When the selected event occurs in 
the test run, the specified action is performed if the Detect Event checkbox is selected or the 
details for the event are stored if the Store Mode is set to Event. You can select from the 
following events:

• Pass - Perform the event action or store the event details when a test passes.

• Fail - Perform the event action or store the event details when a test fails.

• Margin < N - Perform the event action or store the event details when a test result margin 
is less than the specified minimum required margin percentage.

At times, you may receive warning messages when the selected event does not logically 
matches with the selected Store Mode. For instance, if the Store Mode is Best, then you can only 
use Pass as the event. Similarly, if the store mode is Worst, you cannot use Pass as the event. 
The tool automatically corrects the event selection in such cases. 

While you select the test configurations, the tool automatically keeps documenting the test 
configurations for your reference in the open listbox in this tab. The Message tab displays the list 
of actions and any warnings if generated.

3 Run the tests. There are several ways to run the selected tests:

• Click  in the toolbar. to run all the selected tests.

• Select a branch in the Select Tests tab and then click  in the toolbar to repeatedly run only 
the tests of the selected branch.

• Click the big Run button in the Run tab.

4 If there are existing test results, you are asked if you would like to keep them or re-test (delete) 
them.

If you would like to keep the existing test results to compare against new results, click Append.

Click Replace if you would like to delete the existing test results.
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5 While the tests are running, status dialogs appear to inform you about the test progress.

When the tests are complete, Results tab is automatically displayed.

See Also • “To set the display preferences" on page 36

Next • “Viewing Results" on page 41
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To set the display preferences

Information, warning, and error conditions can occur while running tests. The display preferences let 
you choose whether message dialogs are shown. And, there are other display preferences that affect 
what happens as tests are run.

1 From the DDR/LPDDR Post Process Compliance Tool's menu, choose View > Preferences....

2 In the Preferences dialog, select the Display tab.

3 In the Display tab, you can choose to show the following types of message prompts:

• Information prompts.

• Warning prompts.

• Error prompts.

4 Also, you can choose to:

• Change the Color Scheme— Choose a background color from Midnight and Platinum options.

• Keep appl ication on top — Always keep the application's main dialog on the top of the logic 
analyzer application. Note that the mid-run dialogs are always displayed on the top.

• Show tool tips — By enabling this option, the tooltips appear as you move the pointer over 
various controls in the application.

5 Click Apply to save the changes and click OK to close the Preferences dialog.

NOTE
Messages that require you to make a choice, such as "OK/Cancel" and "Yes/No" are always 
enabled.
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7 Automating the Tests

In the Automate tab, you can automate the required tests by selecting either of the following options 
from the Execute commands from section:

• Scripts

• Files

Prerequisites

1 Click Settings. The Automation Settings window appears.

2 Check and change (if required) the appropriate settings and click Close.
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Automation by Scripts

Perform the following steps to automate the tests by scripts:

1 Write the automation programs/commands in the top pane.

2 Click Save As... to save the automation script on your local system.

3 Click Start.
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7

Automation by Files

Perform the following steps to automate the tests by files:

1 Click Add... to load the required file. The loaded file is displayed in the upper pane. 

2 Click Start.
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8 Viewing Results

1 Click the Resul ts tab.

The Results tab contains three re-sizable panes for test results information. If you select one of 
the tests in the top pane, details and reference images (if any) are shown in the lower panes.

TIP A quick way to reset all configuration options and delete all test results is to create a new project 
(see page 53). The new project will have default configuration options. 
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For each individual test that you selected to run, the tool reports the total number of failures that 
occurred for that specific test. It can show up to a maximum of 250 failures in the Details screen for 
an individual test.

Each limit is measured as the time between two states. Each logic analyzer state has a number and a 
timestamp. In case of a failure, the numbers of the two states will be reported. Note that the time 
stamps are only as good as the time stamp resolution of the logic analyzer card being used (this 
resolution may be as coarse as 2ns; see the Specifications and Characteristics in the logic analyzer's 
Online help for details).

If a test case is not encountered in the logic analyzer trace:

• In the details for the test, the number of tests will be 0.

• For limit tests, the “Actual Value” column will display “N/A.”

• For pass/fail tests, the “Actual Value” column will display “Pass.”

See Also • “To change margin thresholds" on page 43

Next • “Viewing/Exporting/Printing the Report" on page 45
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Viewing Results 8

To change margin thresholds

1 From the DDR/LPDDR Post Process Compliance Tool's menu, choose View>Preferences....

2 In the Preferences dialog, select the Resul ts tab.

3 In the Margin Reporting area, you can:

• Enable or disable margin highlighting.

• You can change the percent of margin at which to give warnings or critical failures.

4 Click OK to close the Preferences dialog.

You can set the display order of test result in Test Display section.

NOTE
The DDR/LPDDR Post Process Compliance Tool runs the tests one time, so the Trial display 
options do not apply.
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9 Viewing/Exporting/Printing 
the Report

• To view the HTML test report, click the Html Report tab.

Clicking on any tests under Test Name section displays the details of the particular test result.
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See Also • “To export the report" on page 47

• “To print the report" on page 49

Next • “Saving Test Projects" on page 51
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Viewing/Exporting/Printing the Report 9

To export the report

1 From the DDR/LPDDR Post Process Compliance Tool's menu, choose File > Export Resul ts.

There are two options for exporting the HTML test report: CSV or HTML.

To export results in
CSV

(comma-separated
values) format

Select the CSV option to export the results as a comma-separated list of values.

The data format is shown in the first line of the exported *.csv file.

Test ID, Test Name, Measured Item, Trial 1 Value
100,"ACTIVATE to PRECHARGE/Auto-PRECHARGE must be < tRASmax",Number of t
ests ,"9"
100,"ACTIVATE to PRECHARGE/Auto-PRECHARGE must be < tRASmax",Number of f
ailures ,"0"
100,"ACTIVATE to PRECHARGE/Auto-PRECHARGE must be < tRASmax",Actual Valu
e,"4.92E-05"
100,"ACTIVATE to PRECHARGE/Auto-PRECHARGE must be < tRASmax",Margin,"29.
9"

To export the
report in HTML

format

There are two options for exporting HTML format test reports:

• Single-File — To save a single-file report, use the “save as” type “Web Archive, single file (.mt)”.
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• Multi-File — If your report is large and you would like to use links within the report, select the 
HTML>Multi-File option. Selecting the multi-file option exports the results as a set of separate 
image and HTML files. It creates a folder with the specified name that may be copied to any 
computer.

To view the exported report, open the HTML file stored in the folder.

NOTE
Single-file reports will not contain hyper-links in the summary table (due to a .mht format 
limitation). If you want these hyper-links, use the multi-file format.
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Viewing/Exporting/Printing the Report 9

To print the report

• To preview the HTML test report printout, choose File>Print Preview... from the menu.

• To print the HTML test report, choose File>Print... from the menu.
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10 Saving Test Projects

To save test settings and results to the current project directory:

1 Choose File>Save Project from the menu.

To save test settings and results to a new project directory:

1 Choose File>Save Project As... from the menu.

2 In the Save Project As... dialog, enter the device name and location.

Project files will be saved in a directory whose name is the device name.

3 Click OK.

See Also • “To set AutoRecovery preferences" on page 52
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To set AutoRecovery preferences

1 From the DDR/LPDDR Post Process Compliance Tool's menu, choose View>Preferences....

2 In the Preferences dialog, select the Save/Load tab.

3 In the AutoRecovery/HTML Report Update section, you can choose:

• To auto-save results after each trial or permutation even if the entire multi-trial is not 
completed. This option enables full recovery.

• To auto-save results only upon the completion of the entire multi-trial.

4 Click Apply to save the changes and click OK to close the Preferences dialog.
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11 Creating or Opening a Test 
Project

To create a new test project:

1 Choose File>New Project... from the menu.

A new, empty project, with all the default settings is created.

To open an existing test project:

1 Choose File>Open Project... from the menu.

2 In the Open dialog, browse to a test project directory and select the desired ".proj" file.

3 Click Open.

See Also • “To set load preferences" on page 54

Next • “Setting Up the Test Environment" on page 27
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To set load preferences

1 From the DDR/LPDDR Post Process Compliance Tool's menu, choose View>Preferences....

2 In the Preferences dialog, select the Save/Load tab.

3 In the Save/Load tab, you can choose to restore saved test selections when loading a project.

4 Click Apply to save the changes and click OK to close the Preferences dialog.
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